We would like to provide you with an update regarding the outage with Amazon Web Services (AWS). As AWS resolved the issue entirely, we have seen all affected Morningstar products restored to their standard service.
We are currently working through our queues to reprocess any delayed feeds and data sets to ensure that clients receive the most up-to-date information. But please note, due to processing times and data availability, clients may experience missing or stale data.
Posted Oct 20, 2025 - 19:10 CDT
Update
We want to provide you with the latest update regarding the earlier outage with Amazon Web Services (AWS), which has impacted access to Morningstar products. AWS has announced that recovery is in progress and they are seeing improvements.
Currently, Morningstar is still experiencing degraded performance due to this issue, which may result in slowness or data delays when using our products. Our technical teams are actively collaborating with AWS to fully resolve the situation and restore performance to normal levels as quickly as possible.
We appreciate your patience and understanding during this time. For the latest updates, please visit status.morningstar.com. If you have additional questions, feel free to contact Morningstar Support.
Posted Oct 20, 2025 - 14:58 CDT
Update
We want to provide you with the latest update regarding the earlier outage with Amazon Web Services (AWS), which has impacted access to Morningstar products. AWS has announced that recovery is in progress and they are seeing improvements.
Currently, Morningstar is still experiencing degraded performance due to this issue, which may result in slowness or data delays when using our products. Our technical teams are actively collaborating with AWS to fully resolve the situation and restore performance to normal levels as quickly as possible.
We appreciate your patience and understanding during this time. For the latest updates, please visit status.morningstar.com. If you have additional questions, feel free to contact Morningstar Support.
Posted Oct 20, 2025 - 14:40 CDT
Monitoring
We want to provide you with the latest update regarding the earlier outage with Amazon Web Services (AWS), which has impacted access to Morningstar products. AWS has announced that recovery is in progress and they are seeing improvements.
Currently, Morningstar is still experiencing degraded performance due to this issue, which may result in slowness or data delays when using our products. Our technical teams are actively collaborating with AWS to fully resolve the situation and restore performance to normal levels as quickly as possible.
We appreciate your patience and understanding during this time. For the latest updates, please visit status.morningstar.com. If you have additional questions, feel free to contact Morningstar Support.
Posted Oct 20, 2025 - 14:24 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:16 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:46 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:19 CDT
Update
Morningstar is experiencing degraded performance and outages due to the earlier outage with Amazon Web Services which impacted access to our products. As such, clients may experience login issues, slowness, or data delays when utilizing products.
Our technical teams are actively working with Amazon to fully resolve and return performance to normal levels as quickly as possible.
We appreciate your patience and will provide updates as more information becomes available. For additional questions, contact Morningstar Support.
Posted Oct 20, 2025 - 08:51 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 08:39 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 08:29 CDT
Identified
Morningstar is experiencing degraded performance due to the earlier outage with Amazon Web Services which impacted access to our products. As such, clients may experience slowness or data delays when utilizing products.
Our technical teams are actively working with Amazon to fully resolve and return performance to normal levels as quickly as possible.
We appreciate your patience and will provide updates as more information becomes available. For additional questions, contact Morningstar Support.
Posted Oct 20, 2025 - 07:58 CDT
This incident affected: Morningstar Advisor Workstation + Direct Advisory Suite (Morningstar Advisor Workstation), Morningstar Fund API Center (Morningstar Fund API Center), Morningstar Equity API Center (Morningstar Equity API Center), Morningstar Managed Investment Data Feeds (Morningstar Managed Investment Data Feeds), Morningstar Global Equity Data Feeds (Morningstar Global Equity Data Feeds), Morningstar Research Feeds (Morningstar Research Feeds), Morningstar Data Services (Morningstar Data Services), Morningstar On Demand (Morningstar On Demand), Morningstar Direct (Morningstar Direct), Morningstar Direct Web Services (Morningstar Direct Web Services), Morningstar Plan Advantage (Morningstar Plan Advantage), Core Advice Solution on Cloud (Core Advice Solution on Cloud), and Morningstar Retirement Manager (Advisor Managed Accounts – Client and RK Portal).